Menu Close

O Pacote Oracle Java11 Installer Não Tem Candidato Para Instalação

Por que você não deve instalar o instalador Oracle Java 11

Existem várias razões pelas quais você não deve instalar o Oracle Java 11 e por que não deve fazer o download. Isso inclui recursos e APIs depreciados, servidores de download lento e falta de suporte a longo prazo. Você também deve estar ciente da baixa qualidade do instalador Oracle Java 11.

APIs e recursos depreciados

Existem várias razões pelas quais você pode encontrar avisos de depreciação ao instalar o Oracle Java 11. Você pode achar que o Oracle Java 11 remove alguns recursos e APIs que você usa regularmente. Por exemplo, se você usar a API do applet, o Oracle Java 11 não o suportará mais. Isso ocorre porque todos os principais fornecedores de navegador da Web removeram o suporte do plug-in Java ou têm planos de removê-lo em uma versão futura.

O Java SE 11 Development Kit (JDK) é o mais recente lançamento de recursos da plataforma Java SE. Inclui novos recursos e aprimoramentos em várias áreas funcionais. Você pode ler sobre essas atualizações nas notas de lançamento. Além dos novos recursos, o JDK 11 contém o mesmo conteúdo que o Java SE 10 edições.

Para aqueles que executam o Oracle Java, é importante instalar a versão mais recente do JDK. Ele contém correções para vulnerabilidades de segurança e o Oracle recomenda que você use o JDK mais recente após cada atualização crítica do patch. Você pode verificar qual versão você está usando visitando a página de linha de linha de segurança do Oracles.

Os lançamentos regulares do LTS também fornecem acesso mais rápido a novos recursos. De acordo com George Saab, vice -presidente do Oracles Java Platform Group, o próximo lançamento do LTS é o Java 21 em 2023. Enquanto você estiver executando as versões do Oracle JDK na produção, você pode esperar receber atualizações gratuitas por três anos. Isso não inclui o custo das assinaturas de suporte à produção corporativa.

Servidores de download lento

As velocidades de download são 91-100 bytes por segundo. Se seus downloads estiverem demorando mais do que isso, talvez seja necessário esperar o download terminar. Existem muitos fatores que podem tornar o download mais lento. Um fator são os Jogos Olímpicos em Londres, que provavelmente afetarão o fluxo de dados de mídia, o que pode afetar as velocidades de download. Outros fatores podem incluir sua paciência e tempo.

Primeiro, você deve garantir que a versão do Java instalada no seu sistema seja a mesma da versão do script do instalador. Você pode descobrir isso verificando a página para sua instalação específica. Você também pode usar o APT para baixar o Oracle JDK. Esta é a versão mais recente e inclui o JRE.

Qualidade relativamente baixa do instalador Oracle Java 11

O instalador Oracle Java 11 é um download de qualidade extremamente baixa que está disponível para Windows e Mac. Este software fornece apenas os patches mínimos de segurança e não será atualizado após um período de 6 meses. Portanto, não é recomendado para uso da produção. Para aqueles que não precisam dos patches de segurança mais recentes e estão em um sistema mais antigo, o Oracle oferece uma versão comercial com atualizações regulares.

Este software tem uma reputação de ser um dos produtos mais inseguros disponíveis. Nos últimos 18 meses, a Java lançou apenas 11 atualizações, seis das quais eram patches críticos de segurança. Além do mais, o atualizador automático do Java sempre inclui software de terceiros. Alguns deles são o McAfee Security Scanner e perguntam à barra de ferramentas, que podem ser indesejados. Os usuários devem optar explicitamente desses programas antes de baixá -los.

Como em todo o software Oracle, a qualidade do instalador Oracle Java 11 é extremamente baixa. O instalador contém vários erros. Se você notar um erro, é importante relatá -lo ao Oracle Support. Isso ajudará os desenvolvedores a resolver o problema. O Oracle encerrará as atualizações públicas do Java 11 em 29 de março.

Leave a Reply

Your email address will not be published. Required fields are marked *